Scenario

When you scan the QR code in the delivery section of the app, a message will be displayed stating "Synchronisation is Needed"


There are two possible reasons for this message.

Causes

Cause 1 - The Customer Does Not Exist

If the customer has not been entered into the portal then iSpaniel will not be able to find it from the QR code and will display this message.

Resolution

Enter the customer details into iSpaniel and sync the application by logging in again.


Cause 2 - The Customer Code is Incorrect

If the customer code is not the same in iSpaniel as on the system that printed the QR code (usually the accounts/invoicing system) then the data in the QR code will not match with the data in iSpaniel causing this message to be displayed.

Resolution

Compare the customer code from iSpaniel to the code the system that prints the QR code and ensure that they match.  Correct the data in iSpaniel so that it matches and sync iSpaniel by logging in again.

Important Note : 

Previous versions of iSpaniel allowed a customer code to be imported that contained a space at the end.  Please check to ensure there are no spaces at the end of the customer code in iSpaniel.